Music information in instrument cluster

jesse.srq

New member
11
0
1
Just bought a Lincoln Continental Black Label which has been a great experience so far! Just one thing though – For some reason, there is no information on the upper left side of the instrument display for music. It just has a little music icon and nothing more. I’ve searched through all of the settings I know of to no avail. Any suggestions?
 

brucelinc

Member
153
40
28
Minneapolis
I wish I had an answer for you but I don't. Mine shows the song title. Is this info missing on all stations and forms of media or just certain ones? Is your Continental new or an early model? All I can suggest is to check and see if you have the latest version of sync 3.

I assume the artist and song title is shown on the center stack screen?
 

jesse.srq

New member
11
0
1
Yes, it's missing from all media sources. It's a 2019 model year, so relatively new. The Sync version is 3.3 which I believe is the latest version for the Conti, although I'm not 100% sure... Everything displays as it should on the APIM, so I'm all good there.

I think that the last thing I do before I reach out to the dealer is to see if Forscan may have a reset option for the IPC module. Maybe that'll help. Thanks for reaching out, and I'll keep you posted!
 

Town

Senior Member
4,551
227
63
Ottawa Ontario Canada
My 2017 Continental is on SYNC3 version 3.0 and Lincoln tells me it is up to date in Canada. My usual radio station does not show the song on the left side of dash in front of driver, some other stations do and some don't. The song always shows up in the center dash when at Home setting.
______________________________
 

jesse.srq

New member
11
0
1
Just got back from the dealership. Apparently this is a little known issue with the 2019 Continental models only. They told me that they've had three other customers bring their Continental in for the same issue. All were 2019 model year. The dealership tried to replace the IPC module on one of the vehicles, but it did not correct the issue. They told me that Lincoln will not really do anything about it at this point unless they start to see more vehicles come in with this same issue...

Town - It's interesting to hear that yours seems to partially work on your 2017. The dealership told me that all vehicles prior to 2019 worked just fine, but this doesn't seem to be the case.

Still haven't tried Forscan for reset options, but I'll give it a try and let you know how it goes.
 

Multitask

Member
86
22
8
So , Radio, USB device, all do not show any info?
Hmm..
Have they or you tried a Factory Reset? All that does it reset all the defaults to Factory. (yes it would mean loosing any presets possibly)

I can say that sometimes my MKZ does not show the music stuff for a short time, or the Sat Radio changes the name of the person but not the song... turning it off and on fixes that...

My 2013 Fusion wouldn't show info for the radio as far as artists and song, but then 2018 Fusion would because it was HD radio
 

jesse.srq

New member
11
0
1
Multitask - Nope, nothing but the little music note icon, no matter what media source. AM/FM HD or standard, USB, phone, SAT, etc... The only thing that I have not tried yet is CD, which the dealer said may possibly work but I have not tried. When I turn off the radio the little music note disappears, and there's nothing at all. I have not performed a factory reset because I do not believe it's an issue with the center stack. I'll look for a Forscan reset of the cluster before I reset to factory settings.

I too had a couple of Fusions. 2015, and then a 2017. Neither had this issue. The Entertainment selection could always be selected on the right display screen in red, which would show any media information being played. No matter what source. It's also concerning to hear that your MKZ seems to have intermittent issues. It leads me to believe that this issue is a bit more pronounced than the dealership has lead me to believe. No matter what model. What year is your MKZ?
 
Last edited:

Multitask

Member
86
22
8
I have a 2020 hybrid. It seems that only the sat radio does that... HD radio and USB device do not...
______________________________
 

G-226739

The dash display works for my iPhone all the time while other sources only display intermittently. Frustrating.
 

Larry Elliott

New member
22
0
1
Just bought a Lincoln Continental Black Label which has been a great experience so far! Just one thing though – For some reason, there is no information on the upper left side of the instrument display for music. It just has a little music icon and nothing more. I’ve searched through all of the settings I know of to no avail. Any suggestions?
I have had this problem with my 2019 since I bought it. You would think someone would call the engineer and ask him what’s going on. I hate spending this much money and some of the features on my car don’t work. I’ve been to several Ford and Lincoln dealers and no one knows anything except they a knowledge that there could be a problem. Why can’t they call Lincoln? It’s a waste of time to call the concierge. I thought a concierge was supposed to help you with things instead of telling you to go to the dealer.
 

Larry Elliott

New member
22
0
1
Multitask - Nope, nothing but the little music note icon, no matter what media source. AM/FM HD or standard, USB, phone, SAT, etc... The only thing that I have not tried yet is CD, which the dealer said may possibly work but I have not tried. When I turn off the radio the little music note disappears, and there's nothing at all. I have not performed a factory reset because I do not believe it's an issue with the center stack. I'll look for a Forscan reset of the cluster before I reset to factory settings.

I too had a couple of Fusions. 2015, and then a 2017. Neither had this issue. The Entertainment selection could always be selected on the right display screen in red, which would show any media information being played. No matter what source. It's also concerning to hear that your MKZ seems to have intermittent issues. It leads me to believe that this issue is a bit more pronounced than the dealership has lead me to believe. No matter what model. What year is your MKZ?
mine shows everything except the radio info
 

jesse.srq

New member
11
0
1
Just got back from the dealership after letting them have a go at a fix. The technician was given a copy of Sync 3.4 upgrade from Ford for the Conti ('18 & '19 MY) to install. All went well with the installation, but it did not correct the issue. The Technician told me that the next step is to reset the asbuilt data in the APIM and the cluster to see if this will be a remedy, but I doubt this will work. The asbuilt data has never been altered on any of these modules. The only changes I've made were to the blinkers going from three auto clicks to five, and adding Bambi mode to the hi-beams & log lamps. Both of these changes require revisions to modules associated with equipment not related to the APIM or cluster... I will bring it back to them to factory modules reset soon. In the meantime, I obtained a really sharp update to Sync that not only looks great but is a bit more refined as well! I'll keep you updated on their next move.
 

Attachments

Last edited:

bbf2530

Junior Member
1,053
439
83
Just got back from the dealership after letting them have a go at a fix. The technician was given a copy of Sync 3.4 upgrade from Ford for the Conti ('18 & '19 MY) to install. All went well with the installation, but it did not correct the issue. The Technician told me that the next step is to reset the asbuilt data in the APIM and the cluster to see if this will be a remedy, but I doubt this will work. The asbuilt data has never been altered on any of these modules. The only changes I've made were to the blinkers going from three auto clicks to five, and adding Bambi mode to the hi-beams & log lamps. Both of these changes require changes to modules associated with modules not related to APIM or cluster... I will bring it back to them to factory modules reset soon. In the meantime, I obtained a really sharp update to Sync that not only looks great but is a bit more refined as well! I'll keep you updated on their next move.
Hi Jesse. If you don't mind me asking, which version of SYNC was your Continental equipped with from the factory? (before the Dealer upgrade to 3.4)

Was it 3.0, 3.3?

Does your SYNC version now display as SYNC 3.4 on your "About SYNC" screen?

EDIT - Oooops...just saw you photo showing it as 3.4. :rolleyes:

Thanks and good luck.
 

jesse.srq

New member
11
0
1
BTW - The 2020 base Continental that they gave me as a loaner has the exact same issue. The dealership told me that it was only an issue with 2019 MY...
 

Larry Elliott

New member
22
0
1
Yes, it's missing from all media sources. It's a 2019 model year, so relatively new. The Sync version is 3.3 which I believe is the latest version for the Conti, although I'm not 100% sure... Everything displays as it should on the APIM, so I'm all good there.

I think that the last thing I do before I reach out to the dealer is to see if Forscan may have a reset option for the IPC module. Maybe that'll help. Thanks for reaching out, and I'll keep you posted!
If the dealer is able to figure it out please post. I’ve been to 3 dealers. Sad thing is I think they are to lazy to call someone at Lincoln and ask them what’s going on. Mine is a 2019 Reserve. I had a 2017 that showed it just fine. The Lincoln concierge told me to check with the local dealer. One of the people I talked to there supposedly found a fix but the Lincoln people can’t even talk to each other.
 

Multitask

Member
86
22
8
Just a shot in the dark.

I have not been in a Conti, so I don't know where the Media would be displayed. But here goes... is it 'supposed' to show in the left side? (just asking)
I see from the pic that it's not showing much in the upper right quadrant of the center screen. So one could assume there is no data for it to show where it is supposed to on the other screen.

Did it show before you made your 'adjustments' ? if still not , then that is not a direction to go. 8)

I also see they have not talked about changing out the APIM, or ACM (probably the ACM, it deals with the media)
 

Larry Elliott

New member
22
0
1
Just a shot in the dark.

I have not been in a Conti, so I don't know where the Media would be displayed. But here goes... is it 'supposed' to show in the left side? (just asking)
I see from the pic that it's not showing much in the upper right quadrant of the center screen. So one could assume there is no data for it to show where it is supposed to on the other screen.

Did it show before you made your 'adjustments' ? if still not , then that is not a direction to go. 8)

I also see they have not talked about changing out the APIM, or ACM (probably the ACM, it deals with the media)
I can’t answer your question yet. This car has never displayed, on the instrument cluster, anything the radio AM, FM, Siriusxm should show. My phone, blue tooth, thumb drive all display the typical data shown on the instrument cluster in the upper left corner.
 

HTML

Top