Is owner-lincoln-com still a working site/service?

Goldendog

New member
1
0
1
I bought my 2016 certified MKC 2 weeks ago from a Lincoln dealer. Per the Sync3 guide and owners manual I understand that I need to register at owner.lincoln.com to update software, use the Lincoln app, and most importantly update maps. When I try to register the site asks for my name and email then based on just that info the site immediately pops up a picture of my car with the correct VIN, with my address, and asking is this my car. So obviously my dealer has done his part and notified Lincoln of my purchase.

It then asks for me to put in and verify a password, check the usual accept terms boxes, and finally to click the finish registration button. I then get a screen that says "System error. Please try again later or contact us". I tried repeatedly for 5 days and only got the same message. I also tried the lost password route but it tells me no such email address even though every time I try to register with the email it responds with my car and VIN number. So then I called the number listed. It took me 5 minutes to get the rep to understand my dilemma who said I needed to talk to the "software support" group. She then transferred me to another rep who had me on hold several times before he said I was being transferred to their escalation group. Now a third 5 minute explanation that I am simply trying to establish a login. The next rep explains that the Lincoln site has had problems with Chrome so I try the process with Edge, Explorer, and Firefox (I had each on my system) and get the same system error result each time. While on a 15 minute hold time I try to login on my wife's laptop--no luck. Finally he returns and tells me "the problem has been identified and is being dealt with by our IT people but we have no estimate of when the service will be back up."

Now 5 days later and still no login. Anyone else run into this? Does the Lincoln owners site usually run smoothly? Or is there a trick to getting a login running that the 3 Lincoln reps ( I suspect they were all overseas) and myself are missing?
 

Town

Senior Member
4,359
111
63
Ottawa Ontario Canada
Welcome to the Forum.

My Continental was purchased nearly 2 years ago. It was registered by my dealer to me in the Ford/Lincoln registry of owners. I was able to register my car as the owner with no problem and get the Sync3 updates.

Perhaps your dealer also used the owner registration procedure so it's the owner of record at Lincoln, with their e-mail address and password. You could talk to your dealer and see if this is their practice and what e-mail address they would have used and what password.

Good luck.
 

bbf2530

Junior Member
181
23
18
I bought my 2016 certified MKC 2 weeks ago from a Lincoln dealer. Per the Sync3 guide and owners manual I understand that I need to register at owner.lincoln.com to update software, use the Lincoln app, and most importantly update maps. When I try to register the site asks for my name and email then based on just that info the site immediately pops up a picture of my car with the correct VIN, with my address, and asking is this my car. So obviously my dealer has done his part and notified Lincoln of my purchase.

It then asks for me to put in and verify a password, check the usual accept terms boxes, and finally to click the finish registration button. I then get a screen that says "System error. Please try again later or contact us". I tried repeatedly for 5 days and only got the same message. I also tried the lost password route but it tells me no such email address even though every time I try to register with the email it responds with my car and VIN number. So then I called the number listed. It took me 5 minutes to get the rep to understand my dilemma who said I needed to talk to the "software support" group. She then transferred me to another rep who had me on hold several times before he said I was being transferred to their escalation group. Now a third 5 minute explanation that I am simply trying to establish a login. The next rep explains that the Lincoln site has had problems with Chrome so I try the process with Edge, Explorer, and Firefox (I had each on my system) and get the same system error result each time. While on a 15 minute hold time I try to login on my wife's laptop--no luck. Finally he returns and tells me "the problem has been identified and is being dealt with by our IT people but we have no estimate of when the service will be back up."

Now 5 days later and still no login. Anyone else run into this? Does the Lincoln owners site usually run smoothly? Or is there a trick to getting a login running that the 3 Lincoln reps ( I suspect they were all overseas) and myself are missing?
Hi Goldendog. I just tried the Lincoln Owners website and it is working, at least for regular logins. So now I will just throw ideas at the wall to see if anything works.

First, similar to what Town stated, I would check with the Dealership person you purchased from, to see if they had already registered the car when you purchased. When I purchased my 2018, I had already registered the car myself. However, the salesperson had also registered my MKZ and gave me a temporary password, which I then changed to a personalized one. Maybe there is a glitch in your case because the salesperson pre-registered you? Just a wild guess

Second, I am not sure what number you called, but perhaps you will have better luck if you call the Lincoln Concierge? I have had very good service and experiences with them. Give it a try.

Let us know how you make out and good luck.
 

MKZ_GA

Member
48
1
8
Georgia
Your email address will not be publicly visible. We will only use it to contact you to confirm your post.

HTML

Top