93 Town Car blowing number 17 fuse immediately

Welcome to the busiest full-spectrum Lincoln community online!

Please join us! We'd really love to have you as a member...

crimson5liter

New member
6
0
1
Hey all, I am looking at this 93 Town Car, 1 owner, immaculate condition and low miles (sub-50). There's 1 issues with it that seems relatively minor:
The #17 fuse keeps blowing as soon as it is put in (about 1 second, maybe). Looking it up, this fuse runs the Courtesy Lamps, EATC Controller Module, Warning Lamps, Power Mirrors, Remote Keyless Entry, and Memory Seats. This coincides with the issues, power mirrors, radio (amp), keyless remote, and interior lamps all do not work. Has anyone heard of this issue before? I found one thread on another forum referencing the exact same thing, so I'm not sure if it's been documented previously.
In addition, the unlock button on the door turns on the running lights and "night time" lights (radio, climate, dash cluster dim).
Anyone have any info on this?
 

crimson5liter

New member
6
0
1
One of those items is shorted. You will need to inspect each one.
Yeah I was going to unhook each item individually and see if that stops the fuse, then inspect whatever was unhooked that was causing it. If that doesn't work, I'll go through the wiring harnesses and check for damage and issues.
 

crimson5liter

New member
6
0
1
One of those items is shorted. You will need to inspect each one.
Pulled the fuse panel off, there was a green / yellow wire shorting ground. Fuse does not blow immediately but will blow after a few minutes now that it is cut. I'm trying to find out what it goes to, but previously when you'd put in a new fuse, the door chime would come on for an instant and then the fuse would blow. Now, nothing happens with a fuse in.
 
Top