Sign up to remove ads. We'd love to have you amongst our ranks! Just click the Register button below!

lincoln forums   lincoln forum
Direct Links: MKZ | MKS | New Continental (Old) | MKT | MKX | MKC | Navigator | Nautilus | Town Car | LS
Lincoln Forum: 2014 Lincoln MKT heated and cooled driver seat problem
Results 1 to 15 of 15
  1. #1
    Join Date
    Nov 2017
    Posts
    8

    Exclamation 2014 Lincoln MKT heated and cooled driver seat problem

    Remove this ad
    Hi guys , I need help with my car. I have a 2014 Lincoln MKT 3.7 fwd and the driver heated and cooled seat it's not working, but the climate control and the switches are working fine and also the passenger seat heated and cooled system works fine. When I turn the switch on I don't hear the click sound coming from the seat module neither I hear the seat blowers sound, I tried this procedure with both heated setting and cooling setting no luck but I tried this procedure on the passenger seat and did work, I turn on the switch and immediately I heard the click sound from the seat module and then I heard both seat blowers working in both setting the heated and the cooling and both worked fine. I checked the fuse box and the system showed that the front seats share the same fuse so the fuse is not the problem, and I checked the harnesses under the seat and all of them are connected and nothing is loose and after that I had nothing to check for so please if anybody knows how to trouble shoot the problem . Thanks

  2. #2
    Join Date
    Jul 2016
    Location
    Houston
    Posts
    90
    What about rear seats? Those working?

  3. #3
    Join Date
    Nov 2017
    Posts
    8
    Yes they work fine only I have problem with th driver seat that's it.

  4. #4
    Join Date
    Jul 2016
    Location
    Houston
    Posts
    90
    The motor could have died. Do you use that feature often? Meaning turn on and off?

  5. #5
    Join Date
    Nov 2017
    Posts
    8
    I just had the car about 3 month ago and I've tried to use this feature about a month ago but no luck.

  6. #6
    Join Date
    Nov 2017
    Posts
    8
    What motor you are referring to? I thought the seat has 2 blowers , and I don't think that both blowers go out at the same time. I am thinking is the module but I don't want to replace it until I diagnose it and that is my problem I don't know how to do it ,plus I've heard it's very expensive to replace so that's why I am asking for help and hoping that is not the problem.

  7. #7
    Slick Fan's Avatar
    Slick Fan is offline Senior Member My Lincoln(s): 2003 TC Signature, 1977 TC, 2003 Aviator
    Join Date
    Jan 2014
    Location
    Utah
    Posts
    483
    It might be the heating element itself. Does the upright heat element work? Meaning the heater in the seat back, not the seat bottom. Does the heated seat indicator for the driver's seat illuminate the same as the passenger indicator?

  8. #8
    Join Date
    Nov 2017
    Posts
    8
    The heated and cooled seat indicator works fine as I mentioned above but the whole driver seat upright and bottom doesn't work at all in both settings cooling and heated. The passenger seat works fine upright and bottom in both settings heated and cooled.

  9. #9
    Join Date
    Jan 2010
    Location
    South Bend, IN
    Age
    71
    Posts
    508
    Mild rant: WHY are so many owners afraid to take their car to the dealerships service department? (Mine is great!)
    If you suspect they're crooked, go to another dealer.
    If, after they diagnose the problem, you feel it's too expensive, tell them NO; but, at least. you'll know the problem and can go elsewhere.
    '11 MKT 3.5 EcoBoost AWD; '14 Jeep Cherokee Ltd. V6 AWD
    '00 Regal 29' Commodore twin 4.3L


  10. #10
    Join Date
    Nov 2017
    Posts
    8
    Mostly of the dealerships they charge you a fee between $99.99 to $149.99 which is the average hour rate for those kind of dealerships and then ,they tell you if you fixe it here within 30 days we will deduct this amount from the labor. Mostly of the time S Gilbert they charge way more to fix it than the diagnose fee that way you either fix it with them or loose the diagnose fee. I take my car to the Lincoln dealership for oil change and regular maintenance and they perform a 50 point inspection for free, but when I asked them about my problem they said it’s not included and in order to know the problem they have to check for electrical components and that’s cost is additional .

  11. #11
    Join Date
    Jul 2016
    Location
    Houston
    Posts
    90
    That is correct Nassmkt. All dealerships will charge around $90 diagnostic fee.

    Gilbert: That's why OP was asking in the forum to save $90.

  12. #12
    Join Date
    Nov 2017
    Posts
    8
    Hi guys, I have good news. Today when I started my car from the remote start I felt my seat warm so I’ve reached to the passenger seat it was warm too, so I repeated the same thing 2 hours later and did work. That’s a good news because now I know that heated seat is working, but only works in remote start mode not when you turn on the switch on the screen and that’s the only problem .

  13. #13
    Join Date
    Jul 2011
    Location
    CHERRY HILL, NJ
    Age
    69
    Posts
    61
    Quote Originally Posted by vinaygoel2000 View Post
    That is correct Nassmkt. All dealerships will charge around $90 diagnostic fee.

    Gilbert: That's why OP was asking in the forum to save $90.
    In NJ 08002, they get $160.00 diagnostic fee.

  14. #14
    Join Date
    Jul 2016
    Location
    Houston
    Posts
    90
    Quote Originally Posted by CARR142 View Post
    In NJ 08002, they get $160.00 diagnostic fee.
    Wow!! Perks of living in the snow, I guess. LOL.

  15. #15
    Join Date
    Jul 2016
    Location
    Houston
    Posts
    90
    Remove this ad
    Quote Originally Posted by Nassmkt View Post
    Hi guys, I have good news. Today when I started my car from the remote start I felt my seat warm so I’ve reached to the passenger seat it was warm too, so I repeated the same thing 2 hours later and did work. That’s a good news because now I know that heated seat is working, but only works in remote start mode not when you turn on the switch on the screen and that’s the only problem .
    That is indeed strange.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •