2010 MKT climate controlled seats

Acmexplosives

New member
2
0
1
My front climate controlled seats stopped working, they are heated and cooled. The rear heated still work. Switched fuses in the engine compartment for the front and back seats, back still worked but no front, fuses are good. Cant seem to find anything on any fuses in passenger compartment. Filters are clean. This is an ecoboost. The owners manual says if the engine falls below 350 rpm and the climate controlled seats are on, the system will be deactivated and need to be reactivated. Can't find anything on how to reactivate. Any help would be greatly appreciated. Thanks
 

RedGeminiPA

Active member
411
76
28
Altoona, PA
When the manual states "deactivated," it simply means "turned off." Restarting the car will allow it to be turned on again. That isn't your issue.

I believe the controllers for the seats are in parallel. The issue could be the driver's seat control module. The same thing happened to my mom's MKX, but she traded it in for the MKT before it was diagnosed by the dealer. I ran into the woman who bought her MKX from the dealer, but didn't have the heart to ask if the seats worked. I'm assuming they were fixed by the dealer, since she didn't comment about them not working.
 

Acmexplosives

New member
2
0
1
When the manual states "deactivated," it simply means "turned off." Restarting the car will allow it to be turned on again. That isn't your issue.

I believe the controllers for the seats are in parallel. The issue could be the driver's seat control module. The same thing happened to my mom's MKX, but she traded it in for the MKT before it was diagnosed by the dealer. I ran into the woman who bought her MKX from the dealer, but didn't have the heart to ask if the seats worked. I'm assuming they were fixed by the dealer, since she didn't comment about them not working.
So the seats work from time to time. Have had a few instances of trying for shits and giggles and they actually come on and work, turn the car off, run into the store, back in the car and they dont work again. I have checked under the seats and all wiring seems to be tight and in place as best as i can tell. Is there somewhere else i should be looking? Would that be a faulty control module issue? thanks for any info
 

Nassmkt

Junior Member
18
6
3
So the seats work from time to time. Have had a few instances of trying for shits and giggles and they actually come on and work, turn the car off, run into the store, back in the car and they dont work again. I have checked under the seats and all wiring seems to be tight and in place as best as i can tell. Is there somewhere else i should be looking? Would that be a faulty control module issue? thanks for any info
Is the problem with both front seats at the same time ??if yes can you check when you turn the switch On you hear a click if not you have a bad control module.they
 
Top