1979 Continental, CS bogging down and dies

hali-linc

New member
1
0
1
Hello all,

I've owned my Lincoln going on 3 years and have had issue after issue with it in terms of keeping it running. Since purchase, it has had a completely new ignition, rebuilt carb, fuel pump, gas tank and sending unit, air filter every year, fuel filters every year, power steering pump, brake master cylinder, rear brake cylinders, front brake pads, voltage regulator and water pump (plus a few other misc items here and there).
My latest issue is intermittent and tends to surface when under load. As I drive the car, it will all of a sudden lose power and then bog itself down to a low idle and stall out. I'm able to slip the car into neutral, start it and then continue along only for it to do it a few more times before either leaving me stranded, or running normally for the remainder of the drive.
It did something similar last summer and I was able to "fix" the issue with a new power valve in the carburetor. Could it have failed again that fast?
Any help with this issue would be greatly appreciated
 

d45murf

New member
5
0
1
Hello all,

I've owned my Lincoln going on 3 years and have had issue after issue with it in terms of keeping it running. Since purchase, it has had a completely new ignition, rebuilt carb, fuel pump, gas tank and sending unit, air filter every year, fuel filters every year, power steering pump, brake master cylinder, rear brake cylinders, front brake pads, voltage regulator and water pump (plus a few other misc items here and there).
My latest issue is intermittent and tends to surface when under load. As I drive the car, it will all of a sudden lose power and then bog itself down to a low idle and stall out. I'm able to slip the car into neutral, start it and then continue along only for it to do it a few more times before either leaving me stranded, or running normally for the remainder of the drive.
It did something similar last summer and I was able to "fix" the issue with a new power valve in the carburetor. Could it have failed again that fast?
Any help with this issue would be greatly appreciated
I do not have an answer but have the same problem with my 1979 Lincoln. If I figure it out I will let you know.
 

lugnuts

New member
6
0
1
if the car has catylitic convertors i would check those. alot of times old convertors get hot and the insides swell up restricting the exhaust gasses from escaping which causes the motor to choke down. This usually happens when they get hot and after the car cools down it will run great until they get hot again.
 

d45murf

New member
5
0
1
if the car has catylitic convertors i would check those. alot of times old convertors get hot and the insides swell up restricting the exhaust gasses from escaping which causes the motor to choke down. This usually happens when they get hot and after the car cools down it will run great until they get hot again.
That is good info. I will check that out!
______________________________
 

d45murf

New member
5
0
1
Thank you! I may put a new duel exhaust on rather than the single on it now. If I do, emissions are gone. We don’t need them in my state as it is registered as antique.
 

d45murf

New member
5
0
1
Thank you! I may put a new duel exhaust on rather than the single on it now. If I do, emissions are gone. We don’t need them in my state as it is registered as antique.
Update- I took the cat conv off and put on a new duel exhaust from engine back and it sounds awesome ... but still bogs down
 

G-271694

Update- I took the cat conv off and put on a new duel exhaust from engine back and it sounds awesome ... but still bogs down
Have you checked the egr valve and tube to make sure its functioning properly? Seems like the only thing left
______________________________
 

lugnuts

New member
6
0
1
Update- I took the cat conv off and put on a new duel exhaust from engine back and it sounds awesome ... but still bogs down
man i woulds bet that was the problem, it seems like youve pretty much covered the major things, althought have you checked the egr valve and its tube to make sure its functioning properly?
 

G-152720

man i woulds bet that was the problem, it seems like youve pretty much covered the major things, althought have you checked the egr valve and its tube to make sure its functioning properly?
My next step was to check the vacuum lines and stuff like that. I changed gas filter before and I will do it again but it doesn’t seem like that type of problem.

One mechanic said he could take carb apart for me and rebuild it but he prefers not to do that. I guess it is a pia?
 

HTML

Top