lincoln forums   lincoln forum
Direct Links: MKZ | MKS | New Continental (Old) | MKT | MKX | MKC | Navigator | Town Car | LS
Lincoln Forum: Check Charging Sytem
Results 1 to 7 of 7
  1. #1
    Lux Guest

    NOS Yellow Marchall Fog Lamps

    Remove this ad

  2. #2
    re-Markable LSC Guest

    NOS Yellow Marchall Fog Lamps

    Oh, I like them.

  3. #3
    W.V. Kelly Guest

    NOS Yellow Marchall Fog Lamps

    They look like the same housings as our stock LSC lamps. It would be good to verify that they\'re all metal. Expect lots for shipping.
    Good luck,
    W. V. Kelly

    BTW... some Brits call them froglamps.

  4. #4
    fulltilt Guest

    NOS Yellow Marchall Fog Lamps

    They don\'t seem to come with the covers, to bad.

  5. #5
    88MK7Man Guest

    NOS Yellow Marchall Fog Lamps

    I have some yellow headlights..... :shifty:

  6. #6
    Join Date
    Feb 2017
    Posts
    1
    i know this is a very old thread but i have to ask. the truck is a 03 aviator. i replaced the battery because was bad. every since then i have the battery light on. i had the alternator checked and it was good. i swapped for a known good one just because. i am still not getting a charge. battery voltage is reading 11.75 and the alternator is reading the same. I have checked the wires for continuity and all is good. i have rest both the grounds that i have found. is there more?
    if don't figure this out there is going to be a giant bonfire in my yard with a lincoln as a starter.

  7. #7
    Join Date
    Mar 2017
    Posts
    15
    Remove this ad
    How's the condition of your cables? As mentioned these cable to have poor connection to the terminals and along the line. If you can try to clean the contacts or use another lines to see if it will make any difference.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •